Jump to content
Sign in to follow this  
Guest steven

RED DEVILS

Recommended Posts

Guest steven

<_< hi I have a 125 gal tank with 20 or so red devils in it.

all the fish are no smaller than five inches,some are as big as 10 inches.

and they are very healthy.but it seems as tho after i do a 50% water change,three or four days later the fish have a white film or slime,its not ick,I have a massive wet/dry drip filter on it with ampel pump power two mag drive 700,and i still have to do water changes every four or five days of 50%or more,what is happening. or what can i do to fix this thanks.

Share this post


Link to post
Share on other sites
Guest seth

<_< hi I have a 125 gal tank with 20 or so red devils in it.

all the fish are no smaller than five inches,some are as big as 10 inches.

and they are very healthy.but it seems as tho after i do a 50% water change,three or four days later the fish have a white film or slime,its not ick,I have a massive wet/dry drip filter on it with ampel pump power two mag drive 700,and i still have to do water changes every four or five days of 50%or more,what is happening. or what can i do to fix this thanks.

969[/snapback]

Share this post


Link to post
Share on other sites

it could be the temperature of the water, kick it up to 85 F, that's where i usaully have mine set up at or I think its that you have too many devils in there. 150g is big, but you also have like 20 of em and they aren't small either. drop some medicin in the tank and turn of your filter. the thing is if they are sick then isolate them in another tank and treat em before the disease spreads. if none of them have died yet then don't worry too much. :ph34r:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×